bartek@aws: ~/news
$ whoami

Bartek Chojnacki

$ AWS Architect · DevOps · Cloud
Tuesday, October 6, 2026

AWS Batch Gets Native CloudWatch Metrics for Better Job Visibility

AWS Batch now automatically publishes job metrics to Amazon CloudWatch, giving you real-time insights into queue health, failure rates, and job durations across the entire job lifecycle. Track state transitions (submitted, running, succeeded, failed) and timing data directly from the AWS Batch or CloudWatch consoles—this feature is live in all AWS regions where Batch operates.

source: [aws/whats-new]

also that day:

Monday, October 5, 2026

AWS IAM Identity Center Gets Network Access Controls for Identity Store

AWS IAM Identity Center now lets you lock down access to your Identity Store API and SCIM API by restricting requests to specific VPC endpoints, source VPCs, or IP ranges. This means your user provisioning workflows and external identity providers can only talk to your identity data from networks you explicitly allow—perfect for tightening security in multi-account setups.

source: [aws/whats-new]

also that day:

Friday, October 2, 2026

Amazon SageMaker Distribution: Critical Command Injection Vulnerability Requires Immediate Action

Amazon SageMaker Unified Studio has a nasty OS command injection bug (CVE-2026-104019) in the startup script that could let project members execute arbitrary code in other users' Spaces. With Trusted Identity Propagation enabled, attackers could snag temporary credentials and impersonate colleagues. AWS has patched supported versions (2.14.12+, 3.9.12+, 4.0.11+, 4.1.11+, 4.2.8+, 4.3.5+, 4.4.3+), deploying automatically on next Space startup. If you're running older versions, upgrade now—older branches are EOL with no fixes available.

source: [aws/security-bulletin]

Loom for AWS Patches Three Critical Security Flaws

Loom for AWS has three nasty vulnerabilities that need your attention. CVE-2026-103956 lets unauthenticated attackers grab full admin access when no identity provider is set up. CVE-2026-103957 and CVE-2026-103958 allow authenticated users to leak OAuth2 tokens and credentials through misconfigured discovery endpoints. Upgrade to version 1.7.0 immediately—this is a must-do, not optional.

source: [aws/security-bulletin]

also that day: