bartek@aws: ~/news
$ whoami

Bartek Chojnacki

$ AWS Architect · DevOps · Cloud
Friday, October 9, 2026

AWS Amplify API Category: Critical Authorization Bypass in Query Resolvers

AWS Amplify API Category has a nasty authorization flaw (CVE-2026-108096) in @aws-amplify/graphql-index-transformer that lets authenticated users read other users' data through crafted queries. You need to update immediately: @aws-amplify/graphql-index-transformer to 3.1.2+, @aws-amplify/graphql-api-construct to 1.21.4+, or @aws-amplify/data-construct to 1.17.4+. This is a serious data exposure risk—patch your AppSync APIs ASAP.

source: [aws/security-bulletin]

AWS Graviton5 Instances Now Available in Asia-Pacific and Europe

Amazon EC2's new C9g, C9gd, M9g, and M9gd instances powered by AWS Graviton5 processors are now live in Malaysia, Seoul, Singapore, and Spain. These chips deliver up to 25% better compute performance than Graviton4, with databases seeing 30% speedups and ML workloads hitting 35% faster execution—plus they're the first to feature the Nitro Isolation Engine for mathematically proven workload isolation.

source: [aws/whats-new]

also that day:

Thursday, October 8, 2026

aws-cdk-lib Security Fix: Symlink Injection in Asset Bundling

aws-cdk-lib versions before 2.267.0 have a nasty vulnerability (CVE-2026-107608) where Docker files can sneak symlinked files into the asset bundling output without them being part of the original input. This could let attackers inject unwanted files into your cloud infrastructure deployments. If you're using AWS CDK with Docker files, update to 2.267.0 or later immediately—this one requires your attention.

source: [aws/security-bulletin]

Amazon Agent Plugins for AWS: Command Injection Vulnerability in databases-on-aws

Amazon Agent Plugins for AWS databases-on-aws plugin (versions before 1.7.1) has a command injection vulnerability (CVE-2026-107322) that could let attackers execute OS commands through crafted database inputs. User action required: upgrade to version 1.7.1 or later immediately. The vulnerability only triggers if an agent invokes the local helper with malicious input, running commands with helper process permissions.

source: [aws/security-bulletin]

AWS Toolkit for Visual Studio Code: Credential Cache Vulnerability Requires Update

AWS Toolkit for Visual Studio Code versions below 4.10.0 have a security flaw where CodeCatalyst bearer tokens are cached with world-readable permissions and not deleted after sessions end. Local attackers could steal these tokens to gain unauthorized access. If you're using this extension, upgrade to version 4.10.0 or later immediately—this one's worth your attention.

source: [aws/security-bulletin]

also that day:

Wednesday, October 7, 2026

Amazon Athena Engine 3 Authorization Flaw Patched

Amazon Athena engine version 3 had missing authorization checks that could've let authenticated users peek at query metadata from other AWS accounts—think account IDs and SQL statements. AWS fixed it on September 1st, and they've confirmed no actual customer data got exposed. Query results, credentials, and S3 data stayed safe. No action needed on your end.

source: [aws/security-bulletin]

QnABot on AWS Authorization Bypass – Update Required if You Deployed Amazon Q Hook

QnABot on AWS versions 7.0.0–7.4.5 have a nasty authorization bypass (CVE-2026-105811) in the optional Amazon Q Business Lambda hook sample that could let authenticated users read arbitrary S3 objects. Good news: you're only affected if you manually deployed this hook—it doesn't ship by default. If you did deploy it, update QnABot to 7.4.6+ and redeploy the hook sample; updating QnABot alone won't cut it.

source: [aws/security-bulletin]

also that day: