bartek@aws: ~/news
$ whoami

Bartek Chojnacki

$ AWS Architect · DevOps · Cloud
Tuesday, July 21, 2026

s2n-tls Patches Two Critical TLS 1.3 Vulnerabilities

s2n-tls (AWS's open-source TLS/SSL library) has two security issues requiring immediate attention. CVE-2026-16317 lets attackers silently drop TLS 1.3 encrypted records without detection due to missing content_type validation. CVE-2026-16318 causes memory leaks in QUIC-enabled deployments during HelloRetryRequest handshakes. Update to v1.7.6 or later—all TLS 1.3 users are affected by the first flaw.

source: [aws/security-bulletin]

smithy-rs Recursion Bug Causes DoS – Update Your AWS SDK for Rust Now

AWS smithy-rs has a nasty recursion vulnerability (CVE-2026-15957) in its JSON, CBOR, and XML deserializers that lets attackers crash your service with deeply nested payloads. If you're running aws-sdk-rust versions before release-2026-06-0, you need to patch immediately – this is a remote DoS that requires zero authentication. The fix is straightforward: upgrade your crates and you're golden.

source: [aws/security-bulletin]

Monday, July 20, 2026

Amazon GuardDuty Investigation Agent Cuts Threat Analysis Time from Hours to Minutes

AWS just dropped an AI-powered investigation agent for GuardDuty that automatically analyzes security findings across your environment—think of it as having a tireless security analyst on your team. As a cloud engineer, you should integrate this into your threat response workflow to slash investigation time and focus on actual remediation instead of manual log digging.

source: [aws/security-blog]

also that day:

Friday, July 17, 2026

AWS HealthOmics MCP Server Path Traversal Vulnerability – Update Required

AWS HealthOmics MCP Server versions 0.0.35 and earlier have a path traversal flaw (CVE-2026-15415) in workflow linters that could let attackers write files outside intended directories. If you're running aws-healthomics-mcp-server, upgrade to version 0.0.36 or later immediately. This affects the workflow_files input processing, so action is required if you use this service.

source: [aws/security-bulletin]

AWS Athena Synapse Connector Vulnerability Requires Immediate Patching

AWS Athena's Synapse connector has a critical flaw (CVE-2026-12283) where specially crafted table names can leak unintended data when queried. If you're running versions v2022.20.1 through v2026.19.1, you need to update immediately—this affects anyone using Athena Query Federation with Azure Synapse. The vulnerability requires attacker access to your Synapse account, but the impact is serious enough that AWS flagged it as Important.

source: [aws/security-bulletin]