bartek@aws: ~/news
$ whoami

Bartek Chojnacki

$ AWS Architect · DevOps · Cloud
Saturday, August 15, 2026
Friday, August 14, 2026

also that day:

Thursday, August 13, 2026

OpenSearch SQL Plugin Vulnerability Lets Users Bypass Security Rules

OpenSearch SQL Plugin versions 2.13–3.6 have a nasty security gap: the Flint extension doesn't properly validate async queries, letting users slip past the SQL grammar deny list through direct queries. If you're running affected versions, you need to update to 3.7 or 2.19.6 ASAP. AWS managed OpenSearch users get automatic fixes via service updates.

source: [aws/security-bulletin]

OpenSearch Security Analytics Plugin: SSRF Vulnerability Requires Update

OpenSearch Security Analytics Plugin has a critical input validation flaw (CVE-2026-18952) that lets authenticated users perform server-side request forgery and read local files. If you're running plugin version 2.15.0 or later, you need to upgrade to 3.5.0 or newer. AWS managed domains are mostly safe since the vulnerable feature isn't enabled by default, but self-managed instances require immediate patching.

source: [aws/security-bulletin]

also that day: